Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 19, 2026 - 08:00 MST
Scheduled
Our engineering team will be performing a scheduled maintenance on Backup as a Service in Phoenix.
Site PHX - BaaS
Product Cloud Backup for Veeam
Reason Product update / upgrade to version 08.90.09.00
Impacted components Lenovo storage array
Details / Risks During this maintenance window, storage paths will be disconnected and backup jobs & replications might be interrupted. All paths will resume as soon as the maintenance is concluded.
Date & time (MST) Feb 19, 2026 8:00 AM to Feb 19, 2026 02:00 PM
Date & time (CET) Feb 19, 2026 04:00 PM to Feb 19, 2026 10:00 PM
Duration 6 hours
Posted Feb 16, 2026 - 10:21 MST
This scheduled maintenance affected: Phoenix (Backup as a Service (BaaS) - Veeam Managed Backups, Backup as a Service (BaaS) - Veeam Cloud Connect).