Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 01, 2025 - 09:00 MST
Scheduled
Hello,
Our engineering team will be performing a scheduled maintenance on Backup as a Service in Phoenix.
Site PHX - BaaS
Product Managed Backup for Microsoft 365
Reason Product update / upgrade to version 8.1.2.180
Impacted components We are continuing to work with our vendor on the issue with the PHX Managed Backup for Office 365 services. The vendor has provided an update containing the fixes. We will begin the update at 9:00 AM MST.
Client Impact - Managed Backup for Office 365 backup jobs are failing to complete.
Details / Risks During this maintenance window, Veeam services will be stopped and backup jobs & replications might be interrupted. Job management using the VBO/VCC(PHX DSC - phxvbo.phoenixnap.com) will be unavailable. All services will resume as soon as the maintenance is concluded.
Date & time (MST) Jul 1, 2025 9:00 AM to Jul 1, 2025 01:00 PM
Date & time (CEST) Jul 1, 2025 06:00 PM to Jul 1, 2025 10:00 PM
Duration 4 hours
Thank you for your patience and understanding as we continue to work towards providing you with the best possible service.
Posted Jul 01, 2025 - 08:36 MST
This scheduled maintenance affected: Phoenix (Managed Backup for Office 365).