Issue detected on backup-as-a-service in Phoenix

Incident Report for phoenixnap

Resolved

We have resolved the issue on our backup-as-a-service in Phoenix. The repair process has completed and all of our systems are now back up and running. We will be monitoring the environment and storage array as needed to ensure everything is operating as expected.

If you continue to have issues or if you have any questions about this incident, feel free to reach out to [email protected].

phoenixNAP NOC / phoenixNAP Cloud Services
Posted Oct 11, 2025 - 12:48 MST

Update

Status - No change - the repair process is still actively running.

Our team has identified the issue with our backup-as-a-service in Phoenix.
Our Engineers are actively troubleshooting this with the vendor at this time to resolve this as quickly as possible.
We will provide updates as they become available. Thank you.

If you have any questions about this incident, feel free to reach out to [email protected].
Posted Oct 10, 2025 - 03:01 MST

Identified

Our team has identified the issue with our backup-as-a-service in Phoenix. Our Engineers are actively troubleshooting this with the vendor at this time to resolve this as quickly as possible. We will provide updates as they become available. Thank you.

If you have any questions about this incident, feel free to reach out to [email protected].
Posted Oct 09, 2025 - 08:33 MST

Investigating

Our team has detected an issue on our backup-as-a-service in Phoenix. We are investigating it and we will provide updates via email and this page shortly.

If you have any questions about this incident, feel free to reach out to [email protected].

phoenixNAP NOC / phoenixNAP Cloud Services
Posted Oct 09, 2025 - 07:34 MST
This incident affected: Phoenix (Backup as a Service (BaaS) - Veeam Managed Backups, Backup as a Service (BaaS) - Veeam Cloud Connect).