Network Issues in PHX Node

Incident Report for phoenixnap

Resolved

Connectivity was restored and all network traffic appears to be passing normally.

If you continue to have issues, please email us at support@phoenixnap.com
Posted Jun 10, 2026 - 13:37 MST

Monitoring

Our engineers have implemented a resolution that appears to have restored connectivity. We are continuing to monitor traffic. If you continue to have issues, please email us at support@phoenixnap.com
Posted Jun 10, 2026 - 12:21 MST

Update

Our engineers are continuing to work on restoring connectivity. Please check back for updates here.

As always, you can also contact our support team at support@phoenixnap.com
Posted Jun 10, 2026 - 12:07 MST

Identified

Our engineers have identified the issue and are working to restore connectivity. We will continue posting updates here as the situation progresses.
Posted Jun 10, 2026 - 11:32 MST

Investigating

Our teams are aware of an issue affecting network connectivity in our Phoenix Node affecting colocation customers. Our engineers are working on a fix and we'll update here as soon as possible.
Posted Jun 10, 2026 - 11:19 MST
This incident affected: Phoenix (Colocation).