Issue Detected on PHX Blend Colo

Incident Report for phoenixnap

Resolved

We have resolved the issue on our Colocation Network Blend in Phoenix that we identified earlier today. All our systems are now back up and running.

If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
Posted May 15, 2026 - 18:31 MST

Update

We are continuing to investigate the issue with our Colocation Network Blend in Phoenix and will provide updates via email and this page shortly.

If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
Posted May 15, 2026 - 17:58 MST

Investigating

Our team has detected an issue on our Colocation Network Blend in Phoenix. We are investigating it, and we will provide updates via email and this page shortly.

If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
Posted May 15, 2026 - 17:26 MST
This incident affected: Phoenix (Colocation).