Backup as a Service (BaaS) - Veeam Managed Backups

Incident Report for phoenixnap

Resolved

We have resolved the issue onBackup as a Service (BaaS) in Phoenix that we identified earlier today. All our systems are now back up and running. All jobs are now functional.

We want you to know that we take this issue very seriously. Please accept our sincere apologies for any inconvenience this may have caused.
Posted Jan 26, 2026 - 20:53 MST

Investigating

Location - PHX DSC
Product - Backup as a Service (BaaS) - Veeam Managed Backups
Severity - Outage

We are currently experiencing an issue with our PHX Backup as a Service (BaaS) -
Veeam Managed Backups environment. We are engaged with the vendor and are
actively troubleshooting this issue. Updates to follow.

Impact - Veeam backup and backup copy jobs are failing. The Veeam Enterprise
Manager is currently unable to process requests.
Posted Jan 26, 2026 - 16:16 MST
This incident affected: Phoenix (Backup as a Service (BaaS) - Veeam Managed Backups).