Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 05, 2026 - 10:00 MST
Scheduled
Dear Valued Client,
phoenixNAP will be conducting a maintenance on our Dedicated Servers infrastructure in our Singapore location. The purpose of this maintenance window is to address an issue with one of our core routers.
During this four-hour window, we do not anticipate disruptions of service. However, we advise you to please monitor your environment in case we experience unexpected issues.
Our Network Engineering Team will be taking all necessary precautions to mitigate any prolonged disturbances.
If you have any questions about this maintenance window, please contact one of our NOC Team members at 877.749.2656 or by email at [email protected].
Thank you for your understanding and patience as we continue to work towards providing you with the best possible service.
Date & time (MST)
Mar 5, 2026, 10:00 AM to Mar 5, 2026 02:00 PM
Date & time (CET)
Mar 5, 2026, 06:00 PM to Mar 5, 2026 10:00 PM
Duration
4 hours
Posted Mar 02, 2026 - 12:07 MST
This scheduled maintenance affected: Singapore (Dedicated Servers).