Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 25, 2025 - 02:00 MST
Scheduled
The phoenixNAP Bare Metal Cloud (BMC) team will be conducting maintenance on our infrastructure. This maintenance may cause network performance issues on BMC servers located in Singapore. The maintenance will take place on Wednesday, June 25, between 8 AM and 9 AM UTC (2 AM to 3 AM MST).
The maintenance is not expected to impact your servers.
Our teams will take all necessary precautions to mitigate any prolonged disturbance within this service window. If you have any questions about this maintenance, please contact our NOC team at (877) 749-2656 or noc@phoenixnap.com.
Thank you for your patience and understanding as we continue to work towards providing you with the best possible service.
phoenixNAP NOC
Posted Jun 18, 2025 - 08:14 MST
This scheduled maintenance affected: Singapore (Bare Metal Cloud).