Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 06, 2025 - 02:00 MST
Scheduled
Our engineering team will be performing a scheduled maintenance on the Data Security Cloud Infrastructure in Phoenix.
Site PHX - DSC
Product Data Security Cloud
Reason Network Device OS Upgrade
Impacted components Network Infrastructure
Details / Risks
The upgrade is required to fix an important vulnerability detected by our scanning systems.
The upgrade itself takes approximately 10 minutes however during the maintenance, a blip in network traffic might be observed while traffic is diverted between our HA pairs. This will happen on 4 occasions. We are not expecting any disruptions on VMs.
Date & time (MST) Nov 6, 2025 02:00 AM 10:00 AM MST
Duration 8 hours
Posted Oct 30, 2025 - 07:15 MST
This scheduled maintenance affected: Phoenix (Data Security Cloud (DSC)).