We are pleased to report that this issue has been resolved. The environment is online and processing backups jobs as expected. We are continuing to monitor the environment as needed. Client impact - None
Posted Jul 03, 2025 - 14:27 MST
Update
We are continuing to experience issues with the PHX Managed Backup for Office 365 services. Unfortunately, we experienced some issue during the update and a few of the environment's components are not operating as expected. While some backup jobs have begun to run successfully, others continue to fail. We are actively engaged with the vendor and are currently pending feedback. There is no ETA for resolution at this time.
Client Impact - Multiple Managed Backup for Office 365 backup jobs are failing to complete.
If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
phoenixNAP NOC / phoenixNAP Cloud Services
Thank you
Posted Jul 01, 2025 - 16:30 MST
Update
We are continuing to work with our vendor on the issue with the PHX Managed Backup for Office 365 services. There is no ETA for resolution at this time.
Client Impact - Managed Backup for Office 365 backup jobs are failing to complete.
If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
phoenixNAP NOC / phoenixNAP Cloud Services
Posted Jun 27, 2025 - 06:19 MST
Update
We are continuing to work with our vendor on the issue with the PHX Managed Backup for Office 365 services. There is no ETA for resolution at this time.
Client Impact - Managed Backup for Office 365 backup jobs are failing to complete.
If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
phoenixNAP NOC / phoenixNAP Cloud Services
Posted Jun 27, 2025 - 01:26 MST
Update
We are continuing to work with our vendor on the issue with the PHX Managed Backup for Office 365 services. There is no ETA for resolution at this time.
Client Impact - Managed Backup for Office 365 backup jobs are failing to complete.
If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
phoenixNAP NOC / phoenixNAP Cloud Services
Posted Jun 26, 2025 - 21:57 MST
Update
We are continuing to work with our vendor on the issue with the PHX Managed Backup for Office 365 services. There is no ETA for resolution at this time.
Client Impact - Managed Backup for Office 365 backup jobs are failing to complete.
If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
phoenixNAP NOC / phoenixNAP Cloud Services
Posted Jun 26, 2025 - 21:13 MST
Update
We are continuing to work with our vendor on the issue with the PHX Managed Backup for Office 365 services. There is no ETA for resolution at this time.
Client Impact - Managed Backup for Office 365 backup jobs are failing to complete.
If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
phoenixNAP NOC / phoenixNAP Cloud Services
Posted Jun 26, 2025 - 20:10 MST
Update
We are continuing to work with our vendor on the issue with the PHX Managed Backup for Office 365 services. There is no ETA for resolution at this time.
Client Impact - Managed Backup for Office 365 backup jobs are failing to complete.
If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
phoenixNAP NOC / phoenixNAP Cloud Services
Posted Jun 26, 2025 - 18:35 MST
Update
We are continuing to work with our vendor on the issue with the PHX Managed Backup for Office 365 services. There is no ETA for resolution at this time.
Client Impact - Managed Backup for Office 365 backup jobs are failing to complete.
If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
phoenixNAP NOC / phoenixNAP Cloud Services
Posted Jun 26, 2025 - 17:29 MST
Update
We are continuing to work with our vendor on the issue with the PHX Managed Backup for Office 365 services. There is no ETA for resolution at this time.
Client Impact - Managed Backup for Office 365 backup jobs are failing to complete.
If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
phoenixNAP NOC / phoenixNAP Cloud Services
Posted Jun 26, 2025 - 17:00 MST
Update
We are continuing to work with our vendor on the issue with the PHX Managed Backup for Office 365 services. There is no ETA for resolution at this time.
Client Impact - Managed Backup for Office 365 backup jobs are failing to complete.
If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
phoenixNAP NOC / phoenixNAP Cloud Services
Posted Jun 26, 2025 - 16:30 MST
Update
We are continuing to work with our vendor on the issue with the PHX Managed Backup for Office 365 services. There is no ETA for resolution at this time.
Client Impact - Managed Backup for Office 365 backup jobs are failing to complete.
If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
phoenixNAP NOC / phoenixNAP Cloud Services
Posted Jun 26, 2025 - 15:32 MST
Investigating
We are currently experiencing an issue with the PHX Managed Backup for Office 365 services. We are actively engaged with the vendor, have escalated this issue to the vendor management team, and are currently pending a fix. There is no ETA for resolution at this time.
Client Impact - Managed Backup for Office 365 backup jobs are failing to complete.
If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
phoenixNAP NOC / phoenixNAP Cloud Services
Posted Jun 26, 2025 - 14:36 MST
This incident affected: Phoenix (Managed Backup for Office 365).