Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 20, 2025 - 01:00 MST
Update
Valued Client,
Our engineering team will be performing maintenance that will affect our Encryption Management Platform (EMP) powered by Fortanix on the Phoenix Data Security Cloud node. After this maintenance, the Data Security Manager (DSM) will be updated to version 4.36.
Site:
Phoenix
Product:
phoenixNAP Encryption Management Platform
MST Date:
March 20, 2025
MST Time:
01:00 AM to 07:00 AM
CET Date:
March 20, 2025
CET Time:
09:00 AM to 03:00 PM
Reason:
Update of Data Security Manager (DSM) to 4.36
Affected Systems:
phoenixNAP Encrypted VM Storage (HSM) & Encryption Management Platform (EMP)
Details/Risks:
We expect no impact during this maintenance. However, there is a risk of disruption to virtual machine encryption processes if more than one Encryption Management Platform hosts experience issues and lose connectivity. The ability to encrypt virtual machines will be restored once the hosts are brought back online. Access to all previously encrypted objects will remain fully functional throughout the upgrade.
Thank you for your understanding and patience as we continue to work toward providing you with the best service possible. Our teams will take every necessary precaution to mitigate any impact during the maintenance process.
If you have any questions about this maintenance window, please contact one of our NOC team members at 877.749.2656 or noc@phoenixnap.com.
Thank you,
phoenixNAP Cloud Services Team
Posted Mar 17, 2025 - 00:28 MST
Update
We will be undergoing scheduled maintenance during this time.
Posted Mar 11, 2025 - 03:28 MST
Scheduled
Valued Client,
Our engineering team will be performing maintenance that will affect our Encryption Management Platform (EMP) powered by Fortanix on the Phoenix Data Security Cloud node. After this maintenance, the Data Security Manager (DSM) will be updated to version 4.36.
Site:
Phoenix
Product:
phoenixNAP Encryption Management Platform
MST Date:
March 17, 2025
MST Time:
01:00 AM to 07:00 AM
CET Date:
March 17, 2025
CET Time:
09:00 AM to 03:00 PM
Reason:
Update of Data Security Manager (DSM) to 4.36
Affected Systems:
phoenixNAP Encrypted VM Storage (HSM) & Encryption Management Platform (EMP)
Details/Risks:
We expect no impact during this maintenance. However, there is a risk of disruption to virtual machine encryption processes if more than one Encryption Management Platform hosts experience issues and lose connectivity. The ability to encrypt virtual machines will be restored once the hosts are brought back online. Access to all previously encrypted objects will remain fully functional throughout the upgrade.
Thank you for your understanding and patience as we continue to work toward providing you with the best service possible. Our teams will take every necessary precaution to mitigate any impact during the maintenance process.
If you have any questions about this maintenance window, please contact one of our NOC team members at 877.749.2656 or noc@phoenixnap.com.
Thank you,
phoenixNAP Cloud Services Team
Posted Mar 02, 2025 - 23:01 MST
This scheduled maintenance affected: Phoenix (Data Security Cloud (DSC)).