Veeam users in PHX DSC cannot log in to the Self-Service Backup Portal

Incident Report for phoenixnap

Resolved

This incident has been resolved.
Posted Dec 04, 2025 - 09:15 MST

Investigating

We are aware of an issue preventing PHX DSC users from accessing the Veeam Self-Service Backup Portal.
Users may experience login failures or inability to load the interface.

Portal URL: https://dsc-vem.phoenixnap.com/vCloud/client_org_name
Impact: Portal login unavailable
Backup Operations: Not impacted — backups are running normally
Posted Dec 04, 2025 - 09:08 MST
This incident affected: Phoenix (Data Security Cloud (DSC), Backup as a Service (BaaS) - Veeam Managed Backups).