S3 Service degraded in PHX

Incident Report for phoenixnap

Identified

We are actively collaborating with our vendor to resolve ongoing issues with our S3 Storage.

While the service remains accessible, connected applications and dependent services may experience intermittent errors. We are monitoring the situation closely alongside our vendor and will share further updates as new information becomes available. There is currently no estimated time of resolution (ETA).

We appreciate your patience as we work toward a full recovery.
Posted Aug 14, 2026 - 10:42 MST

Update

Following the cooling issue at our Phoenix (PHX) facility, the Cloud Object Storage service is currently unavailable.
Our engineering team is still actively working with the vendor to restore service.
We will provide further updates as more information becomes available.
ETA: N/A
Posted Aug 14, 2026 - 07:07 MST

Investigating

Following the cooling issue at our Phoenix (PHX) facility, the Cloud Object Storage service is currently unavailable.
Our engineering teams are actively working to restore service.
We will provide further updates as more information becomes available.
ETA: N/A
Posted Aug 14, 2026 - 03:24 MST
This incident affects: Phoenix (Object Storage Service (OSS)).