Power degradation event in the Ashburn Databank facility

Incident Report for phoenixnap

Resolved

At this time the issues appear to be resolved and we are back to operational. If you continue to have issues, please contact us at support@phoenixnap.com
Posted Jun 25, 2026 - 15:17 MST

Update

We are currently responding to a cooling-related issue in a portion of the facility. The issue has been identified, and corrective actions have been implemented to restore cooling operations.

Temperatures are steadily decreasing and returning toward normal operating levels. Datacenter operations personnel remain actively engaged in monitoring conditions and completing recovery activities to ensure continued stability.

We will continue to provide updates as additional information becomes available. Thank you for your patience and understanding.
Posted Jun 25, 2026 - 05:12 MST

Update

Following a power-related incident affecting our local data center, the majority of impacted devices and services have successfully recovered and are operating normally.
Our engineering team continues to monitor the environment and is working to restore the remaining affected systems. We will provide further updates as progress continues.
We appreciate your patience and understanding.
Posted Jun 25, 2026 - 04:29 MST

Investigating

A power degradation event has been detected in the Ashburn Databank facility. We are actively investigating the issue and assessing any potential impact to services. Further updates will be provided as they become available.
Posted Jun 25, 2026 - 04:16 MST
This incident affected: Ashburn (Colocation, Dedicated Servers, Bare Metal Cloud).