Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 27, 2026 - 02:00 MST
Scheduled
Our engineering team will be performing a scheduled maintenance on Data Security Cloud Infrastructure in Ashburn.
Site
Ashburn
Product
Data Security Cloud
Reason
Network Device OS Upgrade and Routing Changes
Impacted components
Network Infrastructure
Details / Risks
The upgrade is required to fix an important vulnerability detected by our scanning systems. Our engineering team will also be performing routing changes that will further improve our failover capability. The upgrade takes approximately 10 minutes; however, during the maintenance, a blip in network traffic might be observed while traffic is diverted between our HA pairs. This will happen on 5 occasions. We are not expecting any disruptions on VMs.
Date & time (MST)
Jan 27, 2026 02:00 AM 10:00 AM MST
Duration
8 hours
Posted Jan 19, 2026 - 06:55 MST
This scheduled maintenance affected: Ashburn (Data Security Cloud (DSC)).