We have resolved the issue on DSC in ASHBURN that we identified earlier today. All our systems are now back up and running. We want you to know that we take this issue very seriously. Please accept our sincere apologies for any inconvenience this may have caused.
Posted Apr 27, 2026 - 03:43 MST
Identified
The VCC, VCCR ,Managed backups, Zerto and VCDA services are currently affected. The DSC service is also impacted; clients are able to log in, however, configuration changes cannot be performed at this time.
Posted Apr 27, 2026 - 00:27 MST
Investigating
Our team has detected an issue on our DSC in ASHBURN. We are investigating it, and we will provide updates via email and this page shortly.
If you have any questions about this incident, feel free to reach out to support@phoenixnap.com.
phoenixNAP NOC
Posted Apr 26, 2026 - 23:05 MST
This incident affected: Ashburn (Data Security Cloud (DSC)).