Issue - PHX VBM365 Self-service portal

Incident Report for phoenixnap

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 11:51 MST

Update

This issue has been resolved.
The self-restore portal is now functioning as expected.
Posted Nov 13, 2025 - 11:51 MST

Investigating

Location - PHX
Product - Managed Backup for Office 365
Severity - Deprecated Performance

----------------------
We are currently experiencing an issue with our PHX Veeam Managed Backup for
Office 365 self-restore portal. We are currently engaging the vendor to assist
with troubleshooting. Updates to follow.

Client Impact -
Clients are unable to utilize the self-restore portal to restore VBM365 data.
Please open a support case in the event a VBM365 restore is required.
([email protected])
Posted Nov 13, 2025 - 11:27 MST
This incident affected: Phoenix (Managed Backup for Office 365).