Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Nov 13, 2025 - 04:46 MST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 13, 2025 - 01:00 MST
Scheduled
Our engineering team will be performing a scheduled maintenance on Virtual Private Data Center in Phoenix and Ashburn.
Site PHX ASH
Product Cloud Object Storage (S3)
Reason Internal security fixes
Impacted components Object Storage
Details / Risks There may be minor disruptions in connectivity to the S3 during its service restart
Date & time (MST) Nov 13, 2025 1:00 AM to Nov 13, 2025 08:00 AM
Date & time (CET) Nov 13, 2025 09:00 AM to Nov 13, 2025 04:00 PM
Duration 7 hours
Posted Nov 12, 2025 - 02:53 MST
This scheduled maintenance affected: Phoenix (Virtual Private Data Center (VPDC), Object Storage Service (OSS)) and Ashburn (Virtual Private Data Center (VPDC), Object Storage).